Platform Support

What platforms are currently supported?

The following operating systems are currently supported with the latest development jNetPcap release. The table below also lists the various hardware architectures and packaging options supported.


Operating SystemVersiontar/zipx86_32x86_64Packager
Windows XPSP1 or aboveXX
Windows VistaSP1 or aboveXX
Windows 7SP1 or aboveXXX
FreeBSD7.1,8.1XXX
Open Solaris2009XXX
Mac/OSX*


Note *: Mac/OSX support is currently under development.

The following Linux variant operating systems are supported. All linux systems can run on the "Generic Linux" tar distribution, even the ones that are not part of the list below as long as they meet the minimum "Linux Kernel" version level and minimum "libpcap" library version of 9.8 for pre jnetpcap 1.4 APIs and libpcap version 1.0.0 or above for jnetpcap 1.4.


[table=theme Linux Systems | Version | tar/zip | x86_32| x86_64 | Packager
Generic Linux | Kernel 2.6.18 or above | X | X | X |
Fedora Core | 8,9,10,11,12 | | X | X | rpm
Redhat Enterprise | 4,5 | X | X | | rpm
Debian | 5 | | X | X | deb
Ubuntu | 9 | | X | X | deb
OpenSUSE* | 11.3 | | X | X | rpm
CentOS | 5.2 | | | |

PcapExtension NotAvailable exception

The exception is telling you that on this particular platform the winpcap extension is not available and can not be used.

WinPcap native library is a windows implementation of libpcap library. It supports all of the libpcap functions and adds several new capabilities but only on windows platforms. jNetPcap API provides WinPcap extension only on windows platform.

In order to avoid having this error thrown, the user must check if WinPcap extension is supported on this particular platform at runtime. To check for support use WinPcap.isSupported():boolean method which will return a boolean true if it is supported, otherwise false. This method never throws an exception and needs to be used before your code relies on any features within that WinPcap package.

Syndicate content